Sims 3 showing up on Task Manager but not Playing.

View previous topic View next topic Go down

Sims 3 showing up on Task Manager but not Playing. Empty Sims 3 showing up on Task Manager but not Playing.

Post by ShadowKarr on Thu 07 Sep 2017, 00:47

I decided to bring Sims 3 back from the dead (since I'm going to wait for Sims 4 Pets to come out in November) so I downloaded the Sims 3 complete collection. When I tried to find the PowerIso file in the Sims 3 base game, (with the collection), I couldn't find it. So I uninstalled it and then reinstalled it, all seemed to be ok. Until I tried to click it, nothing happened. So, I opened my Task Manager, and it showed the Sims 3 Launcher was working but nothing showed up. My Sims 4 is still mounted on PowerIso but I can't unmount it to let Sims 3 have a go. So I'm not sure what's going on. Any help/advice would be greatly appreciated. Thanks Smile

P.S. I'm on Windows Vista (Sims 3 has worked on here before I had any problems).

ShadowKarr
Beginner
Beginner

Favourite games : Sims 3 and Sims 4

Posts : 3
Points : 813
Join date : 2017-09-07

Back to top Go down

Sims 3 showing up on Task Manager but not Playing. Empty Re: Sims 3 showing up on Task Manager but not Playing.

Post by Guest on Thu 07 Sep 2017, 10:45

The easiest way to play/repair your Sims 3 is via ZLOrigin.

Guest
Guest


Back to top Go down

Sims 3 showing up on Task Manager but not Playing. Empty Re: Sims 3 showing up on Task Manager but not Playing.

Post by The_gh0stm4n on Thu 07 Sep 2017, 16:49

@ShadowKarr wrote:I decided to bring Sims 3 back from the dead (since I'm going to wait for Sims 4 Pets to come out in November) so I downloaded the Sims 3 complete collection. When I tried to find the PowerIso file in the Sims 3 base game, (with the collection), I couldn't find it. So I uninstalled it and then reinstalled it, all seemed to be ok. Until I tried to click it, nothing happened. So, I opened my Task Manager, and it showed the Sims 3 Launcher was working but nothing showed up. My Sims 4 is still mounted on PowerIso but I can't unmount it to let Sims 3 have a go. So I'm not sure what's going on. Any help/advice would be greatly appreciated. Thanks Smile

P.S. I'm on Windows Vista (Sims 3 has worked on here before I had any problems).


Hello and welcome to the Forum,

There is no .ISO file in the G4TW "Complete Collection". You only need to extract all contents of the .rar file, in a fresh folder, for example on the desktop, and with WinRAR. Bear in mind the extraction can take a while. When done follow the included installation guide.

I don't know what exactly you did, but if you feel the game was installed correctly, please try this here:
http://games4theworld.forumotion.com/t23881-game-doesn-t-start-no-specific-error-fix

Good luck!

_________________
The_gh0stm4n
The_gh0stm4n
G4TW Forum Gatekeeper
Inspector General & Sergeant-At-Arms
G4TW Forum Gatekeeper Inspector General & Sergeant-At-Arms

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Team Fortress 2, Overwatch, PvZ: Garden Warfare, Call of Duty: Ghosts, GTA: San Andreas, Counter-Strike, Hitman, Borderlands, The Binding of Isaac, Government simulation & Military strategy games, S.W.A.T. 4, GTA V / GTA Online.

Male

Posts : 18136
Points : 24524
Join date : 2012-11-02

Back to top Go down

Sims 3 showing up on Task Manager but not Playing. Empty Re: Sims 3 showing up on Task Manager but not Playing.

Post by ShadowKarr on Thu 14 Sep 2017, 02:49

Thanks for replying, guys. Okay, here's what I did: I remembered a Sims 3 fix that I completely forgot about so I did that. Good news is, Sims 3 opens but the bad news is Sims 3 stops working!! I know I probably put the Expansions and Stuff Packs in the wrong place (in the Sims 3 Folder itself) so I checked the Installation Guide that came with the Sims 3 Complete Collection but there's nothing to say where to install them.

P.S. Ok, after I 'installed' a couple of Packs (Late Night and Pets from the Complete Collection) the launcher does come up but it says that there was an error during startup. Please see the Log for more details.


Last edited by ShadowKarr on Thu 14 Sep 2017, 04:00; edited 2 times in total (Reason for editing : To Put More Info)

ShadowKarr
Beginner
Beginner

Favourite games : Sims 3 and Sims 4

Posts : 3
Points : 813
Join date : 2017-09-07

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum