Help running mods on TS4!

View previous topic View next topic Go down

Help running mods on TS4!

Post by fredetchic on Sun 11 Nov 2018, 13:43

Hi all,

First, congrats for this site: explanations are very clear and detailed Carlos is tha man 

So, here is the problem:

I wanted to install the sims 4 for my daughter.
I then downloaded several package: Mr DJ repack, qoob repack and finally "The Sims 4 all-in version 1.46.18.1020.iso" from there (the package that doesn't need installation).

No matter the version I've tryed to install, I still get the same troubles!

Everytime, game starts fine, basegame is working, no alert of any kind, no error, no message in the game. But... the mods appeared as owned but everytime I try to click on one, it ask me to connect and so it fails loading the mod (I choose to stay offline but it doesn't work. when tryied to connect, says it could not connect).

Here is my config: windows 7 ultimate 64. No antivirus of any kind, windows defender disabled.

I've done the following:
1. Installed (or copied files for The Sims 4 all-in version 1.46.18.1020.iso) to program files or to another partition
2. Installed in a folder called The Sims 4 or with another name
3. Changed language to french or left it in english
4. Tryied on 2 different computers with same OS
5. Tryied to disable all pack but one (kept city leaving) with dlc-toggler.exe to see if it could be a dlc that would cause trouble
6. run it as administrator
7. tryied 32 and 64 bits version
8. turn firewall on and block ts4_64 or turn firewall off

Everytime, still get the same results as explained previously!

With other repack, it has installed all the windows library (visual, etc..)

I first thought it was because I didn't have Origin installed so I installed it. Didn't changed anything (online/offline/turned off)

I uninstalled origin and installed ZLorigin instead.

Connect to ZLorigin with an account and set it online / offline. When trying to run a mod, it says Origin has been closed



Everytime it tells me Connection is required when I click on an expansion pack / game pack / stuff pack...


It's driving me nuts and I have to admit I'm fed up downloading over 80 Go of useless files since they all gave me the same result.

I may have missed something cause I got exactly the same results with various repack on both computers...

So, any hints?

Do I need to have Origin / ZLorigin installed?
Do I need to connect to origin / ZLorigin with an account?
Do I need to turn Origin / ZLorigin off?
Do I need to have Origin / ZLorigin running but set it up Offline?

Do I need to install something else that files included in the package here ?

I'm out of ressource Sad

Fred

fredetchic
Beginner
Beginner

Favourite games : TS4

Posts : 2
Points : 101
Reputation : 0
Join date : 2018-11-11

View user profile

Back to top Go down

Re: Help running mods on TS4!

Post by anadius on Sun 11 Nov 2018, 13:57

You mean DLCs (Expansion Packs, Game Packs and Stuff Packs), mods are game modifications created by users.

Don't click on those icons, just click play button. You can confirm DLCs are installed when playing. Items from those DLCs have icon next to them:

_________________
The Sims 4: alternative installer v2 | gallery downloader | validator | language changer and DLC toggler
Feel free to send me an e-mail if you encounter any problem with my installers/programs.
anadius
anadius
G4TW Forum Developer
Think-tank driver
G4TW Forum Developer Think-tank driver

Favourite games : puzzle games

Posts : 1627
Points : 4167
Reputation : 439
Join date : 2013-07-01

View user profile https://ts4installer.tumblr.com/

Back to top Go down

Re: Help running mods on TS4!

Post by fredetchic on Sun 11 Nov 2018, 14:33

Oh my God! I'll kill my daughter Smile Smile
In fact, with your package, everything was working fine! It's about 2 days I try to troubleshot something that was actually running fine!

thansk a lot, you're da king Wink

fredetchic
Beginner
Beginner

Favourite games : TS4

Posts : 2
Points : 101
Reputation : 0
Join date : 2018-11-11

View user profile

Back to top Go down

Re: Help running mods on TS4!

Post by The_gh0stm4n on Sun 11 Nov 2018, 20:23

@fredetchic wrote:Oh my God! I'll kill my daughter Smile Smile
In fact, with your package, everything was working fine! It's about 2 days I try to troubleshot something that was actually running fine!

thansk a lot, you're da king Wink


These visual indicators on the main menu about the DLCs ("icons") are really there for marketing-psychological reasons. Hovering with the mouse over one of these flashy icons givens a brief audio-effect I think, but either way, it's really just intended to entice people to spend money on DLC that are grey, in that main menu.

_________________
The_gh0stm4n
The_gh0stm4n
G4TW Training Administrator
Inspector General & Site Gatekeeper
G4TW Training AdministratorInspector General & Site Gatekeeper

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Team Fortress 2, Overwatch, PvZ: Garden Warfare, GTA: San Andreas, GTA V / GTA Online, Counter-Strike, Hitman, Borderlands, Fallout, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth †, Government simulation & Military strategy games, S.W.A.T 4.

Male

Posts : 17068
Points : 23007
Reputation : 2533
Join date : 2012-11-02
Location : Bellisarius Hall

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum